[MediaWiki-l] Failed to upgrade from 1.32.5 to 1.33.1

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Failed to upgrade from 1.32.5 to 1.33.1

Valerio Pelliccioni
Hi, there,

I'm not new to the MediaWiki update process.

I have already updated major and minor releases in the past (i.e. from 1.29 to 1.32 and from 1.32 to 1.32.5).

Today I tried to update to 1.33.1 and after performing all the preparatory steps:

. Check the requirements

. Read the release notes

. Back up existing files and the database

. Unpack the new files in a new and empty folder on my server

. Upgrade extensions

. Copied all files (and directories) from the old installation (images, LocalSettings, skins, etc.)

 

I run the update script but, unlike the previous updates, the wiki

. did not show my default skin (Metrolook),

. did not show images,

. did not show the SideBar

. and especially did not allow me (WikiSysop, nor other users) to login (the wiki asked me to provide a password longer than 8 characters)

 

I didn't investigate any further; these result was enough for me to go back to my footsteps...restored the wikiDB, run the update script in the old (1.32.5) maintenance directory and now everything works fine (as expected).

 

Did I forget any steps, or made something wrong during the update process?

 

ProductVersion
MediaWiki1.32.5
PHP7.2.17-0ubuntu0.18.04.1 (apache2handler)
MariaDB10.1.38-MariaDB-0ubuntu0.18.04.1

 

Any little help is appreciated.

 

Valerio Pelliccioni

W: https://tunearch.org

 

 

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Failed to upgrade from 1.32.5 to 1.33.1

Valerio Pelliccioni
Hi, there,

I partially solved the problem thanks to a precious suggestion (thanks Hershel): to update the version of Metrolook to 1.33 (which I had not done).

Now the skin is the correct one, I see the SideBar and also the images.

I still have the problem of not being able to access my wiki with my administrator credentials (WikiSysop) or with those of any other user, i.e: NO LOGIN at all.

 

Given that the update script did not show any errors except this one (for Anonymous and some other user):

 

... rev_id=8578

User name "Anonymous" is usable, cannot create an anonymous actor for it. Run maintenance/cleanupUsersWithNoId.php to fix this situation

 

What else can I do?

 

Valerio Pelliccioni

W: https://tunearch.org/ 

 

 

From: "Valerio M. Pelliccioni" <[hidden email]>
Date: Monday, 16 December 2019 at 11:53
To: MediaWiki announcements and site admin list <[hidden email]>
Subject: Failed to upgrade from 1.32.5 to 1.33.1

 

Hi, there,

I'm not new to the MediaWiki update process.

I have already updated major and minor releases in the past (i.e. from 1.29 to 1.32 and from 1.32 to 1.32.5).

Today I tried to update to 1.33.1 and after performing all the preparatory steps:

. Check the requirements

. Read the release notes

. Back up existing files and the database

. Unpack the new files in a new and empty folder on my server

. Upgrade extensions

. Copied all files (and directories) from the old installation (images, LocalSettings, skins, etc.)

 

I run the update script but, unlike the previous updates, the wiki

. did not show my default skin (Metrolook),

. did not show images,

. did not show the SideBar

. and especially did not allow me (WikiSysop, nor other users) to login (the wiki asked me to provide a password longer than 8 characters)

 

I didn't investigate any further; these result was enough for me to go back to my footsteps...restored the wikiDB, run the update script in the old (1.32.5) maintenance directory and now everything works fine (as expected).

 

Did I forget any steps, or made something wrong during the update process?

 

ProductVersion
MediaWiki1.32.5
PHP7.2.17-0ubuntu0.18.04.1 (apache2handler)
MariaDB10.1.38-MariaDB-0ubuntu0.18.04.1

 

Any little help is appreciated.

 

Valerio Pelliccioni

W: https://tunearch.org

 

 

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Failed to upgrade from 1.32.5 to 1.33.1

Brian Wolff
Try adjusting $wgPasswordPolicy (
https://www.mediawiki.org/wiki/Manual:$wgPasswordPolicy ) in
LocalSettings.php

Follow the update script's advice about cleanupUsersWithNoId.php

--
Bawolff

On Monday, December 16, 2019, Valerio Pelliccioni <[hidden email]> wrote:

> Hi, there,
>
> I partially solved the problem thanks to a precious suggestion (thanks
> Hershel): to update the version of Metrolook to 1.33 (which I had not done).
>
> Now the skin is the correct one, I see the SideBar and also the images.
>
> I still have the problem of not being able to access my wiki with my
> administrator credentials (WikiSysop) or with those of any other user, i.e:
> NO LOGIN at all.
>
>
>
> Given that the update script did not show any errors except this one (for
> Anonymous and some other user):
>
>
>
> ... rev_id=8578
>
> User name "Anonymous" is usable, cannot create an anonymous actor for it.
> Run maintenance/cleanupUsersWithNoId.php to fix this situation
>
>
>
> What else can I do?
>
>
>
> Valerio Pelliccioni
>
> W: https://tunearch.org/
>
>
>
>
>
> From: "Valerio M. Pelliccioni" <[hidden email]>
> Date: Monday, 16 December 2019 at 11:53
> To: MediaWiki announcements and site admin list <
> [hidden email]>
> Subject: Failed to upgrade from 1.32.5 to 1.33.1
>
>
>
> Hi, there,
>
> I'm not new to the MediaWiki update process.
>
> I have already updated major and minor releases in the past (i.e. from
> 1.29 to 1.32 and from 1.32 to 1.32.5).
>
> Today I tried to update to 1.33.1 and after performing all the preparatory
> steps:
>
> . Check the requirements
>
> . Read the release notes
>
> . Back up existing files and the database
>
> . Unpack the new files in a new and empty folder on my server
>
> . Upgrade extensions
>
> . Copied all files (and directories) from the old installation (images,
> LocalSettings, skins, etc.)
>
>
>
> I run the update script but, unlike the previous updates, the wiki
>
> . did not show my default skin (Metrolook),
>
> . did not show images,
>
> . did not show the SideBar
>
> . and especially did not allow me (WikiSysop, nor other users) to login
> (the wiki asked me to provide a password longer than 8 characters)
>
>
>
> I didn't investigate any further; these result was enough for me to go
> back to my footsteps...restored the wikiDB, run the update script in the
> old (1.32.5) maintenance directory and now everything works fine (as
> expected).
>
>
>
> Did I forget any steps, or made something wrong during the update process?
>
>
>
> ProductVersion
> MediaWiki1.32.5
> PHP7.2.17-0ubuntu0.18.04.1 (apache2handler)
> MariaDB10.1.38-MariaDB-0ubuntu0.18.04.1
>
>
>
> Any little help is appreciated.
>
>
>
> Valerio Pelliccioni
>
> W: https://tunearch.org
>
>
>
>
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Failed to upgrade from 1.32.5 to 1.33.1

Valerio Pelliccioni
I didn't know anything about this policy... my fault.
That solved the problem.
Thank you so much Brian.

/V

´╗┐On 16/12/2019, 16:18, "MediaWiki-l on behalf of Brian Wolff" <[hidden email] on behalf of [hidden email]> wrote:

    Try adjusting $wgPasswordPolicy (
    https://www.mediawiki.org/wiki/Manual:$wgPasswordPolicy ) in
    LocalSettings.php
   
    Follow the update script's advice about cleanupUsersWithNoId.php
   
    --
    Bawolff
   
    On Monday, December 16, 2019, Valerio Pelliccioni <[hidden email]> wrote:
   
    > Hi, there,
    >
    > I partially solved the problem thanks to a precious suggestion (thanks
    > Hershel): to update the version of Metrolook to 1.33 (which I had not done).
    >
    > Now the skin is the correct one, I see the SideBar and also the images.
    >
    > I still have the problem of not being able to access my wiki with my
    > administrator credentials (WikiSysop) or with those of any other user, i.e:
    > NO LOGIN at all.
    >
    >
    >
    > Given that the update script did not show any errors except this one (for
    > Anonymous and some other user):
    >
    >
    >
    > ... rev_id=8578
    >
    > User name "Anonymous" is usable, cannot create an anonymous actor for it.
    > Run maintenance/cleanupUsersWithNoId.php to fix this situation
    >
    >
    >
    > What else can I do?
    >
    >
    >
    > Valerio Pelliccioni
    >
    > W: https://tunearch.org/
    >
    >
    >
    >
    >
    > From: "Valerio M. Pelliccioni" <[hidden email]>
    > Date: Monday, 16 December 2019 at 11:53
    > To: MediaWiki announcements and site admin list <
    > [hidden email]>
    > Subject: Failed to upgrade from 1.32.5 to 1.33.1
    >
    >
    >
    > Hi, there,
    >
    > I'm not new to the MediaWiki update process.
    >
    > I have already updated major and minor releases in the past (i.e. from
    > 1.29 to 1.32 and from 1.32 to 1.32.5).
    >
    > Today I tried to update to 1.33.1 and after performing all the preparatory
    > steps:
    >
    > . Check the requirements
    >
    > . Read the release notes
    >
    > . Back up existing files and the database
    >
    > . Unpack the new files in a new and empty folder on my server
    >
    > . Upgrade extensions
    >
    > . Copied all files (and directories) from the old installation (images,
    > LocalSettings, skins, etc.)
    >
    >
    >
    > I run the update script but, unlike the previous updates, the wiki
    >
    > . did not show my default skin (Metrolook),
    >
    > . did not show images,
    >
    > . did not show the SideBar
    >
    > . and especially did not allow me (WikiSysop, nor other users) to login
    > (the wiki asked me to provide a password longer than 8 characters)
    >
    >
    >
    > I didn't investigate any further; these result was enough for me to go
    > back to my footsteps...restored the wikiDB, run the update script in the
    > old (1.32.5) maintenance directory and now everything works fine (as
    > expected).
    >
    >
    >
    > Did I forget any steps, or made something wrong during the update process?
    >
    >
    >
    > ProductVersion
    > MediaWiki1.32.5
    > PHP7.2.17-0ubuntu0.18.04.1 (apache2handler)
    > MariaDB10.1.38-MariaDB-0ubuntu0.18.04.1
    >
    >
    >
    > Any little help is appreciated.
    >
    >
    >
    > Valerio Pelliccioni
    >
    > W: https://tunearch.org
    >
    >
    >
    >
    >
    > _______________________________________________
    > MediaWiki-l mailing list
    > To unsubscribe, go to:
    > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
    >
    _______________________________________________
    MediaWiki-l mailing list
    To unsubscribe, go to:
    https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
   



_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l