[MediaWiki-l] Mediawiki installation asking for already provided components

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Mediawiki installation asking for already provided components

Sharon Kimble

After installing Debian 9 after a hard-drive died I'm now having
problems getting my local installation of mediawiki up and running. I'm
using this page as my guide [1] and copied and pasted the stanza "sudo
apt-get install apache2 mysql-server php php-mysql libapache2-mod-php
php-xml php-mbstring" and installed everything for a 'stretch'
installation.

This was not an upgrade of my OS but a straight install using the
'stretch' net-install.iso.

I have installed 'php-xml:all 1:7.0+49' and 'php7.0-mbstring:amd64
7.0.19-1' but the "http://localhost/mediawiki/" is saying -

--8<---------------cut here---------------start------------->8---
MediaWiki 1.28 internal error

Installing some PHP extensions is required.

Required components

You are missing a required extension to PHP that MediaWiki requires to run. Please install:

mbstring (more information)
xml (more information)
--8<---------------cut here---------------end--------------->8---

So what versions are required then please for a successful mediawiki
local installation please?

Thanks
Sharon.


[1] - https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:Running_MediaWiki_on_Debian_or_Ubuntu
--
A taste of linux = http://www.sharons.org.uk
TGmeds = http://www.tgmeds.org.uk
DrugFacts = https://www.drugfacts.org.uk 
Debian 9.0, fluxbox 1.3.5-2, emacs 25.1.1, org-mode 9.0.7

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

signature.asc (847 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Mediawiki installation asking for already provided components

Bartosz Dziewoński
Hmm. Make sure the mbstring and xml extensions are enabled in your php.ini
file?

--
Matma Rex
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l