[MediaWiki-l] Missing article text after 1.32.5 upgrade?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Missing article text after 1.32.5 upgrade?

Jeffrey Walton
Hi Everyone,

I upgraded from MW 1.32.4 to 1.32.5 today. I noticed the body of some
articles are missing their text. For example, notice the synopsis for
https://www.cryptopp.com/w/index.php?search=Nmake . It has part of the
lead paragraph.

However, when we follow to the article the text is missing. It is not isolated:

* https://www.cryptopp.com/wiki/Nmake_(Command_Line)
* https://www.cryptopp.com/wiki/Scrypt
* https://www.cryptopp.com/wiki/P1363_KDF2
* https://www.cryptopp.com/wiki/PKCS12_PBKDF
  ...

We regularly run one of the scripts in maintenance/ to collapse
article history. I think the script is deleteOldRevisions.php or
deleteArchivedRevisions.php . We don't need history due to our
workflows.

Does anyone know what might be causing the issue?

Jeff

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Missing article text after 1.32.5 upgrade?

Jeffrey Walton
On Thu, Dec 5, 2019 at 5:35 AM Jeffrey Walton <[hidden email]> wrote:

>
> I upgraded from MW 1.32.4 to 1.32.5 today. I noticed the body of some
> articles are missing their text. For example, notice the synopsis for
> https://www.cryptopp.com/w/index.php?search=Nmake . It has part of the
> lead paragraph.
>
> However, when we follow to the article the text is missing. It is not isolated:
>
> * https://www.cryptopp.com/wiki/Nmake_(Command_Line)
> * https://www.cryptopp.com/wiki/Scrypt
> * https://www.cryptopp.com/wiki/P1363_KDF2
> * https://www.cryptopp.com/wiki/PKCS12_PBKDF
>   ...
>
> We regularly run one of the scripts in maintenance/ to collapse
> article history. I think the script is deleteOldRevisions.php or
> deleteArchivedRevisions.php . We don't need history due to our
> workflows.
>
> Does anyone know what might be causing the issue?

Cancel.

This seems to be a Firefox on Windows 8.1 problem.

Firefox on Linux is OK. Private Browsing Windows on Windows is OK.

Jeff

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Missing article text after 1.32.5 upgrade?

Jeffrey Walton
On Thu, Dec 5, 2019 at 6:11 AM Jeffrey Walton <[hidden email]> wrote:

>
> On Thu, Dec 5, 2019 at 5:35 AM Jeffrey Walton <[hidden email]> wrote:
> >
> > I upgraded from MW 1.32.4 to 1.32.5 today. I noticed the body of some
> > articles are missing their text. For example, notice the synopsis for
> > https://www.cryptopp.com/w/index.php?search=Nmake . It has part of the
> > lead paragraph.
> >
> > However, when we follow to the article the text is missing. It is not isolated:
> >
> > * https://www.cryptopp.com/wiki/Nmake_(Command_Line)
> > * https://www.cryptopp.com/wiki/Scrypt
> > * https://www.cryptopp.com/wiki/P1363_KDF2
> > * https://www.cryptopp.com/wiki/PKCS12_PBKDF
> >   ...
> >
> > We regularly run one of the scripts in maintenance/ to collapse
> > article history. I think the script is deleteOldRevisions.php or
> > deleteArchivedRevisions.php . We don't need history due to our
> > workflows.
> >
> > Does anyone know what might be causing the issue?
>
> Cancel.
>
> This seems to be a Firefox on Windows 8.1 problem.
>
> Firefox on Linux is OK. Private Browsing Windows on Windows is OK.

It appears the problem is MobileView.

I was testing some of the appearance themes after the upgrade. One of
the things I tested was MobileView. After clicking MobileView, all the
article text disappears.

Jeff

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Missing article text after 1.32.5 upgrade?

Brian Wolff
This isnt consistent with the mobile view part, but this sounds like the
issue with imported users that can be fixed by running
cleanupUsersWithNoId.php followed by migrateActors.php

--
Brian

On Thursday, December 5, 2019, Jeffrey Walton <[hidden email]> wrote:

> On Thu, Dec 5, 2019 at 6:11 AM Jeffrey Walton <[hidden email]> wrote:
> >
> > On Thu, Dec 5, 2019 at 5:35 AM Jeffrey Walton <[hidden email]>
> wrote:
> > >
> > > I upgraded from MW 1.32.4 to 1.32.5 today. I noticed the body of some
> > > articles are missing their text. For example, notice the synopsis for
> > > https://www.cryptopp.com/w/index.php?search=Nmake . It has part of the
> > > lead paragraph.
> > >
> > > However, when we follow to the article the text is missing. It is not
> isolated:
> > >
> > > * https://www.cryptopp.com/wiki/Nmake_(Command_Line)
> > > * https://www.cryptopp.com/wiki/Scrypt
> > > * https://www.cryptopp.com/wiki/P1363_KDF2
> > > * https://www.cryptopp.com/wiki/PKCS12_PBKDF
> > >   ...
> > >
> > > We regularly run one of the scripts in maintenance/ to collapse
> > > article history. I think the script is deleteOldRevisions.php or
> > > deleteArchivedRevisions.php . We don't need history due to our
> > > workflows.
> > >
> > > Does anyone know what might be causing the issue?
> >
> > Cancel.
> >
> > This seems to be a Firefox on Windows 8.1 problem.
> >
> > Firefox on Linux is OK. Private Browsing Windows on Windows is OK.
>
> It appears the problem is MobileView.
>
> I was testing some of the appearance themes after the upgrade. One of
> the things I tested was MobileView. After clicking MobileView, all the
> article text disappears.
>
> Jeff
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Missing article text after 1.32.5 upgrade?

Jeffrey Walton
On Thu, Dec 5, 2019 at 11:22 AM Brian Wolff <[hidden email]> wrote:
>
> This isnt consistent with the mobile view part, but this sounds like the issue with imported users that can be fixed by running cleanupUsersWithNoId.php followed by migrateActors.php

Thanks.

Does this look normal? I have never run the script, so I don't know
what normal looks like.

(The SERVER_NAME complaint is normal for this wiki).

-----

# php cleanupUsersWithNoId.php --prefix=* --conf=../LocalSettings.php

Notice: Undefined index: SERVER_NAME in
/var/www/html/w/includes/GlobalFunctions.php on line 1416

Notice: Undefined index: SERVER_NAME in
/var/www/html/w/includes/GlobalFunctions.php on line 1416
...Update 'CleanupUsersWithNoId' already logged as completed.

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Missing article text after 1.32.5 upgrade?

Brian Wolff
That would be the message if it already ran (you can use --force to make it
run again. It is safe to run multiple times). If its already been run, my
guess would be that the issue is something else.

--
Brian

On Thursday, December 5, 2019, Jeffrey Walton <[hidden email]> wrote:

> On Thu, Dec 5, 2019 at 11:22 AM Brian Wolff <[hidden email]> wrote:
> >
> > This isnt consistent with the mobile view part, but this sounds like the
> issue with imported users that can be fixed by running
> cleanupUsersWithNoId.php followed by migrateActors.php
>
> Thanks.
>
> Does this look normal? I have never run the script, so I don't know
> what normal looks like.
>
> (The SERVER_NAME complaint is normal for this wiki).
>
> -----
>
> # php cleanupUsersWithNoId.php --prefix=* --conf=../LocalSettings.php
>
> Notice: Undefined index: SERVER_NAME in
> /var/www/html/w/includes/GlobalFunctions.php on line 1416
>
> Notice: Undefined index: SERVER_NAME in
> /var/www/html/w/includes/GlobalFunctions.php on line 1416
> ...Update 'CleanupUsersWithNoId' already logged as completed.
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l