[MediaWiki-l] Next Mediawiki upgrade given CentOS 7 with PHP 7.1.30?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Next Mediawiki upgrade given CentOS 7 with PHP 7.1.30?

Jeffrey Walton
Hi Everyone,

We upgraded to 1.32.6 today. Everything looks OK. The 1.32.6 release
announcement said this is the last upgrade, and we should switch to
1.33 or 1.34.

We rent a CentOS 7 VM. It is fully patched. We enabled Software
Collections (SCL) to get something more modern for Apache and PHP. SCL
provides:

  * Apache 2.4.34
  * PHP 7.1.30
  * MariaDB 5.5.64

Also see https://www.cryptopp.com/wiki/Special:Version.

When we try the next upgrade to 1.34.0, we get the following when
trying to update the Vendor gear:

# php -d extension=phar.so composer.phar update
Do not run Composer as root/super user! See
https://getcomposer.org/root for details
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - This package requires php >=7.2.9 but your PHP version (7.1.30)
does not satisfy that requirement.
  Problem 2
    - Installation request for mediawiki/mediawiki-codesniffer 28.0.0
-> satisfiable by mediawiki/mediawiki-codesniffer[v28.0.0].
    - mediawiki/mediawiki-codesniffer v28.0.0 requires php >= 7.2.0 ->
your PHP version (7.1.30) does not satisfy that requirement.

What is the highest version of Mediawiki we can upgrade to?

Thanks in advance.

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Next Mediawiki upgrade given CentOS 7 with PHP 7.1.30?

Andre Klapper
Hi,

On Thu, 2019-12-19 at 11:53 -0500, Jeffrey Walton wrote:

> We upgraded to 1.32.6 today. Everything looks OK. The 1.32.6 release
> announcement said this is the last upgrade, and we should switch to
> 1.33 or 1.34.
>
> We rent a CentOS 7 VM. It is fully patched. We enabled Software
> Collections (SCL) to get something more modern for Apache and PHP.
> SCL
> provides:
>
>   * Apache 2.4.34
>   * PHP 7.1.30
>   * MariaDB 5.5.64
>
> Also see https://www.cryptopp.com/wiki/Special:Version.
>
> When we try the next upgrade to 1.34.0, we get the following when
> trying to update the Vendor gear:
>
> # php -d extension=phar.so composer.phar update
> Do not run Composer as root/super user! See
> https://getcomposer.org/root for details
> > ComposerHookHandler::onPreUpdate
> Loading composer repositories with package information
> Updating dependencies (including require-dev)
> Your requirements could not be resolved to an installable set of
> packages.
>
>   Problem 1
>     - This package requires php >=7.2.9 but your PHP version (7.1.30)
> does not satisfy that requirement.
>   Problem 2
>     - Installation request for mediawiki/mediawiki-codesniffer 28.0.0
> -> satisfiable by mediawiki/mediawiki-codesniffer[v28.0.0].
>     - mediawiki/mediawiki-codesniffer v28.0.0 requires php >= 7.2.0
> ->
> your PHP version (7.1.30) does not satisfy that requirement.
>
> What is the highest version of Mediawiki we can upgrade to?

https://en.wikipedia.org/wiki/MediaWiki_version_history says that 1.33
is the last version to support PHP 7.1. MediaWiki version 1.33 will
probably be supported until approx. June 2020.

Note that MediaWiki version 1.31 is a Long Term Support (LTS) version
supported until approx. June 2021.

andre
--
Andre Klapper (he/him) | Bugwrangler / Developer Advocate
https://blogs.gnome.org/aklapper/


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] Next Mediawiki upgrade given CentOS 7 with PHP 7.1.30?

John Horne
On Thu, 2019-12-19 at 20:43 +0100, Andre Klapper wrote:

> Hi,
>
> On Thu, 2019-12-19 at 11:53 -0500, Jeffrey Walton wrote:
> > We upgraded to 1.32.6 today. Everything looks OK. The 1.32.6 release
> > announcement said this is the last upgrade, and we should switch to
> > 1.33 or 1.34.
> >
> > We rent a CentOS 7 VM. It is fully patched. We enabled Software
> > Collections (SCL) to get something more modern for Apache and PHP.
> > SCL
> > provides:
> >
> >   * Apache 2.4.34
> >   * PHP 7.1.30
> >   * MariaDB 5.5.64
> >
> > Also see https://www.cryptopp.com/wiki/Special:Version.
> >
> > When we try the next upgrade to 1.34.0, we get the following when
> > trying to update the Vendor gear:
> >
...

> > What is the highest version of Mediawiki we can upgrade to?
>
> https://en.wikipedia.org/wiki/MediaWiki_version_history says that 1.33
> is the last version to support PHP 7.1. MediaWiki version 1.33 will
> probably be supported until approx. June 2020.
>
> Note that MediaWiki version 1.31 is a Long Term Support (LTS) version
> supported until approx. June 2021.
>
Hi,

We have mediawiki running on CentOS 7 with SCL, but using wiki version 1.31 for
the very reason it offered long term support. We are starting to look at
RHEL/CentOS 8, and I suspect that before mid-2021 we will move the wiki onto a
CentOS 8 server. CentOS 8.0 currently offers PHP 7.2, but I gather that CentOS
8.1 will offer PHP 7.3 as well. With the use of modules in RHEL/CentOS 8, we
should be able to keep up to date better with software requirements (PHP in
this case) as required by mediawiki.

Anyway, that's the plan... :-)


John.

--
John Horne | Senior Operations Analyst | Technology and Information Services
University of Plymouth | Drake Circus | Plymouth | Devon | PL4 8AA | UK
________________________________
[http://www.plymouth.ac.uk/images/email_footer.gif]<http://www.plymouth.ac.uk/worldclass>

This email and any files with it are confidential and intended solely for the use of the recipient to whom it is addressed. If you are not the intended recipient then copying, distribution or other use of the information contained is strictly prohibited and you should not rely on it. If you have received this email in error please let the sender know immediately and delete it from your system(s). Internet emails are not necessarily secure. While we take every care, University of Plymouth accepts no responsibility for viruses and it is your responsibility to scan emails and their attachments. University of Plymouth does not accept responsibility for any changes made after it was sent. Nothing in this email or its attachments constitutes an order for goods or services unless accompanied by an official order form.
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l