[MediaWiki-l] RFC: Drop support for database upgrade of mediawiki older than two LTS releases

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] RFC: Drop support for database upgrade of mediawiki older than two LTS releases

Amir Sarabadani
Hello,
If you're not maintaining a mediawiki instance or don't work with mediawiki's installer/updater, feel free to ignore this email (sorry for spam).

The aforementioned RFC has reached phase 3, which means we need to reach out to stakeholders and since this RFC is going to impact third party installations, hence this email.

Currently and in theory, mediawiki supports upgrading from 1.2 (released in 2004) to its current version but if this RFC is approved, you wouldn't be able to upgrade from versions older than two LTS releases. So for example for upgrading to 1.35, you can't upgrade to it from 1.26 or lower, 1.26 was released in end of 2015 and EOL'd in end of 2016, if you want to upgrade from 1.26, you have to first upgrade to 1.34 and then you would be able to upgrade to 1.35 [Note that this is an example, 1.35 is already released and thus not affected by this RFC, this is going to affect future releases].

Here's the RFC: https://phabricator.wikimedia.org/T259771 Feel free to chime in and spread the word to other stakeholders.

Thanks
--
Amir (he/him)


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l