[MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages

Schoenemann, P. Thomas
I’ve installed tinyMCE on my installation but for several pages it just doesn’t work.  I get a delay, then the tinyMCE menu, but then no text shows up below it for editing (even though there is text, and I can see it by selecting “Edit source” instead of “Edit” (which invokes tinyMCE).  I’m running mediawiki 1.31.0, and my server is running 7.3.13 (which I can’t change).  Any ideas?

FYI I installed tinyMCE by going to my extensions folder and doing:

git clone https://gerrit.wikimedia.org/r/mediawiki/extensions/TinyMCE.git

It completes with no errors.

I then put:

wfLoadExtension( 'TinyMCE' );

in my LocalSettings.php

Suggestions?  A bug?

-Tom




_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages

Andre Klapper
On Thu, 2020-01-09 at 22:09 +0000, Schoenemann, P. Thomas wrote:

> I’ve installed tinyMCE on my installation but for several pages it
> just doesn’t work.  I get a delay, then the tinyMCE menu, but then no
> text shows up below it for editing (even though there is text, and I
> can see it by selecting “Edit source” instead of “Edit” (which
> invokes tinyMCE).  I’m running mediawiki 1.31.0, and my server is
> running 7.3.13 (which I can’t change).  Any ideas?
>
> FYI I installed tinyMCE by going to my extensions folder and doing:
>
> git clone
> https://gerrit.wikimedia.org/r/mediawiki/extensions/TinyMCE.git

Sounds like you installed git master (=unstable development 1.35.x
version) of TinyMCE together with an outdated insecure MediaWiki
version (1.31.0).

Does this problem still happen with a maintained MediaWiki version
(currently 1.31.6 for LTS, see https://www.mediawiki.org/wiki/Download
and https://www.mediawiki.org/wiki/Manual:Upgrading ) and the
corresponding TinyMCE branch (REL1_31)?

andre
--
Andre Klapper (he/him) | Bugwrangler / Developer Advocate
https://blogs.gnome.org/aklapper/


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages

duncan.crane
Hi Tom

Thank you for trying this extension.  Andre's advice is good, however, I recreated your environment (except I'm using PHP 7.1.33) and found that it should work.  Unfortunately I was unable to reproduce your problem although I tried a number of complex pages that I use as test cases.  

Problems similar to this haver occurred in the past.  Usually it is some combination of wiki-markup that breaks the code which parses it into html (eg. a bug as you say).  If you go into your browser's 'debug' mode, usually by right clicking and selecting 'inspect', it should display if an error has occurred and in which bit of the code.

If you let me know if there is an error and where in the code it is happening that will help me to find a solution.  Even better, if you can isolate the wiki-markup that gives rise to the problem that will be even more helpful.

I am going to move this discussion to the Talk page of the TinyMCE extension (https://www.mediawiki.org/wiki/Extension_talk:TinyMCE) as this is where most issues have been covered so please do reply there.  The thread should be there in a few minutes.

Kind regards

Duncan
 

-----Original Message-----
From: MediaWiki-l <[hidden email]> On Behalf Of Andre Klapper
Sent: 10 January 2020 06:10
To: MediaWiki announcements and site admin list <[hidden email]>
Subject: Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages

On Thu, 2020-01-09 at 22:09 +0000, Schoenemann, P. Thomas wrote:

> I’ve installed tinyMCE on my installation but for several pages it
> just doesn’t work.  I get a delay, then the tinyMCE menu, but then no
> text shows up below it for editing (even though there is text, and I
> can see it by selecting “Edit source” instead of “Edit” (which invokes
> tinyMCE).  I’m running mediawiki 1.31.0, and my server is running
> 7.3.13 (which I can’t change).  Any ideas?
>
> FYI I installed tinyMCE by going to my extensions folder and doing:
>
> git clone
> https://gerrit.wikimedia.org/r/mediawiki/extensions/TinyMCE.git

Sounds like you installed git master (=unstable development 1.35.x
version) of TinyMCE together with an outdated insecure MediaWiki version (1.31.0).

Does this problem still happen with a maintained MediaWiki version (currently 1.31.6 for LTS, see https://www.mediawiki.org/wiki/Download
and https://www.mediawiki.org/wiki/Manual:Upgrading ) and the corresponding TinyMCE branch (REL1_31)?

andre
--
Andre Klapper (he/him) | Bugwrangler / Developer Advocate https://blogs.gnome.org/aklapper/


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l



_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages

Schoenemann, P. Thomas
In reply to this post by Schoenemann, P. Thomas
Thanks for the suggestions.  Some questions:

Where does one get the latest stable version of tinyMCE?

Here is the entirety of the “download” section for “extension:tinyMCE” (https://www.mediawiki.org/wiki/Extension:TinyMCE):
Download[edit<https://www.mediawiki.org/w/index.php?title=Extension:TinyMCE&action=edit&section=1>]
You can download the TinyMCE code, in .zip format, here<https://github.com/wikimedia/mediawiki-extensions-TinyMCE/archive/0.3.zip>.
You can also download the code directly via Git from the MediaWiki source code repository (see available tags<https://phabricator.wikimedia.org/diffusion/ETMC/tags/master/>). From a command line, you can call the following:

git clone https://gerrit.wikimedia.org/r/mediawiki/extensions/TinyMCE.git


To view the code online, including version history for each file, go here<https://phabricator.wikimedia.org//r/p/mediawiki/extensions/TinyMCE;browse/master/>.

Note:
1) there is no indication that the git link leads to a unstable development version of TinyMCE.  Is this something that users are just supposed to know?  If so, it would be good for the developers to included some short note about this, and how users with less experience with MediaWiki etc. can go about getting the stable version.
2) that the last link (“To view the code online, including version history for each file, go here”) points to a page that reads: "The requested project does not exist”.

-Tom


Message: 2
Date: Fri, 10 Jan 2020 07:09:48 +0100
From: Andre Klapper <[hidden email]<mailto:[hidden email]>>
To: MediaWiki announcements and site admin list
<[hidden email]<mailto:[hidden email]>>
Subject: Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the
underlying text on some pages
Message-ID:
<[hidden email]<mailto:[hidden email]>>
Content-Type: text/plain; charset="UTF-8"

On Thu, 2020-01-09 at 22:09 +0000, Schoenemann, P. Thomas wrote:
I’ve installed tinyMCE on my installation but for several pages it
just doesn’t work.  I get a delay, then the tinyMCE menu, but then no
text shows up below it for editing (even though there is text, and I
can see it by selecting “Edit source” instead of “Edit” (which
invokes tinyMCE).  I’m running mediawiki 1.31.0, and my server is
running 7.3.13 (which I can’t change).  Any ideas?

FYI I installed tinyMCE by going to my extensions folder and doing:

git clone
https://gerrit.wikimedia.org/r/mediawiki/extensions/TinyMCE.git

Sounds like you installed git master (=unstable development 1.35.x
version) of TinyMCE together with an outdated insecure MediaWiki
version (1.31.0).

Does this problem still happen with a maintained MediaWiki version
(currently 1.31.6 for LTS, see https://www.mediawiki.org/wiki/Download
and https://www.mediawiki.org/wiki/Manual:Upgrading ) and the
corresponding TinyMCE branch (REL1_31)?

andre
--
Andre Klapper (he/him) | Bugwrangler / Developer Advocate
https://blogs.gnome.org/aklapper/




------------------------------

Subject: Digest Footer

_______________________________________________
MediaWiki-l mailing list
[hidden email]<mailto:[hidden email]>
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l


------------------------------

End of MediaWiki-l Digest, Vol 196, Issue 5
*******************************************
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages

Schoenemann, P. Thomas
I updated to MediaWiki 1.31.6, and installed the 0.3 version of TinyMCE by downloading from here: https://github.com/wikimedia/mediawiki-extensions-TinyMCE/archive/0.3.zip (which is where the "You can download the TinyMCE code, in .zip format..” on the Extension:TinyMCE mediawiki page points to) and then uploading to the server running my mediawiki installation.  Now TinyMCE does seem to work properly, so that must have been the issue.  Thanks for pointing me in the right direction. I’d still like to know how one might use the git method to get a stable version, for future reference. That way I won’t have to download locally and upload to my server.  Perhaps there is a way to download directly to the server from a web page using command line?

Thanks,
-Tom

On Jan 10, 2020, at 1:58 PM, Schoenemann, P. Thomas <[hidden email]<mailto:[hidden email]>> wrote:

Thanks for the suggestions.  Some questions:

Where does one get the latest stable version of tinyMCE?

Here is the entirety of the “download” section for “extension:tinyMCE” (https://www.mediawiki.org/wiki/Extension:TinyMCE):
Download[edit<https://www.mediawiki.org/w/index.php?title=Extension:TinyMCE&action=edit&section=1>]
You can download the TinyMCE code, in .zip format, here<https://github.com/wikimedia/mediawiki-extensions-TinyMCE/archive/0.3.zip>.
You can also download the code directly via Git from the MediaWiki source code repository (see available tags<https://phabricator.wikimedia.org/diffusion/ETMC/tags/master/>). From a command line, you can call the following:

git clone https://gerrit.wikimedia.org/r/mediawiki/extensions/TinyMCE.git


To view the code online, including version history for each file, go here<https://phabricator.wikimedia.org//r/p/mediawiki/extensions/TinyMCE;browse/master/>.

Note:
1) there is no indication that the git link leads to a unstable development version of TinyMCE.  Is this something that users are just supposed to know?  If so, it would be good for the developers to included some short note about this, and how users with less experience with MediaWiki etc. can go about getting the stable version.
2) that the last link (“To view the code online, including version history for each file, go here”) points to a page that reads: "The requested project does not exist”.

-Tom


Message: 2
Date: Fri, 10 Jan 2020 07:09:48 +0100
From: Andre Klapper <[hidden email]<mailto:[hidden email]>>
To: MediaWiki announcements and site admin list
<[hidden email]<mailto:[hidden email]>>
Subject: Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the
underlying text on some pages
Message-ID:
<[hidden email]<mailto:[hidden email]>>
Content-Type: text/plain; charset="UTF-8"

On Thu, 2020-01-09 at 22:09 +0000, Schoenemann, P. Thomas wrote:
I’ve installed tinyMCE on my installation but for several pages it
just doesn’t work.  I get a delay, then the tinyMCE menu, but then no
text shows up below it for editing (even though there is text, and I
can see it by selecting “Edit source” instead of “Edit” (which
invokes tinyMCE).  I’m running mediawiki 1.31.0, and my server is
running 7.3.13 (which I can’t change).  Any ideas?

FYI I installed tinyMCE by going to my extensions folder and doing:

git clone
https://gerrit.wikimedia.org/r/mediawiki/extensions/TinyMCE.git

Sounds like you installed git master (=unstable development 1.35.x
version) of TinyMCE together with an outdated insecure MediaWiki
version (1.31.0).

Does this problem still happen with a maintained MediaWiki version
(currently 1.31.6 for LTS, see https://www.mediawiki.org/wiki/Download
and https://www.mediawiki.org/wiki/Manual:Upgrading ) and the
corresponding TinyMCE branch (REL1_31)?

andre
--
Andre Klapper (he/him) | Bugwrangler / Developer Advocate
https://blogs.gnome.org/aklapper/




------------------------------

Subject: Digest Footer

_______________________________________________
MediaWiki-l mailing list
[hidden email]<mailto:[hidden email]>
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l


------------------------------

End of MediaWiki-l Digest, Vol 196, Issue 5
*******************************************


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages

duncan.crane
Hi Tom,

I am glad you've got this working using an earlier version of the extension as found in the 'zip' file.

As I mentioned yesterday, the 'master' version should be stable so I think you have identified a bug in that version.  Unfortunately I cannot reproduce it without the information I was asking for yesterday.  I'd be grateful if you would provide this information as then I could fix the bug so you and others could use the 'master' version without problems.

Thanks also for identifying the problem with the documentation (your Note 2, below).  The project does exist in Phabricator but it is not listed in 'Module:Callsigns' which is used by the template 'git file' to create the link in the documentation.  I can place a link in the documentation directly to the Phabricator page but it might be better if 'Module:Callsigns' was updated to reflect the current contents of Phabricator.  Sadly, this is beyond my limited knowledge of mediawiki so I may need a little help with doing this from someone else on this mailing list?

Kind regards

Duncan

-----Original Message-----
From: MediaWiki-l <[hidden email]> On Behalf Of Schoenemann, P. Thomas
Sent: 10 January 2020 20:04
To: [hidden email]
Subject: Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages

I updated to MediaWiki 1.31.6, and installed the 0.3 version of TinyMCE by downloading from here: https://github.com/wikimedia/mediawiki-extensions-TinyMCE/archive/0.3.zip (which is where the "You can download the TinyMCE code, in .zip format..” on the Extension:TinyMCE mediawiki page points to) and then uploading to the server running my mediawiki installation.  Now TinyMCE does seem to work properly, so that must have been the issue.  Thanks for pointing me in the right direction. I’d still like to know how one might use the git method to get a stable version, for future reference. That way I won’t have to download locally and upload to my server.  Perhaps there is a way to download directly to the server from a web page using command line?

Thanks,
-Tom

On Jan 10, 2020, at 1:58 PM, Schoenemann, P. Thomas <[hidden email]<mailto:[hidden email]>> wrote:

Thanks for the suggestions.  Some questions:

Where does one get the latest stable version of tinyMCE?

Here is the entirety of the “download” section for “extension:tinyMCE” (https://www.mediawiki.org/wiki/Extension:TinyMCE):
Download[edit<https://www.mediawiki.org/w/index.php?title=Extension:TinyMCE&action=edit&section=1>]
You can download the TinyMCE code, in .zip format, here<https://github.com/wikimedia/mediawiki-extensions-TinyMCE/archive/0.3.zip>.
You can also download the code directly via Git from the MediaWiki source code repository (see available tags<https://phabricator.wikimedia.org/diffusion/ETMC/tags/master/>). From a command line, you can call the following:

git clone https://gerrit.wikimedia.org/r/mediawiki/extensions/TinyMCE.git


To view the code online, including version history for each file, go here<https://phabricator.wikimedia.org//r/p/mediawiki/extensions/TinyMCE;browse/master/>.

Note:
1) there is no indication that the git link leads to a unstable development version of TinyMCE.  Is this something that users are just supposed to know?  If so, it would be good for the developers to included some short note about this, and how users with less experience with MediaWiki etc. can go about getting the stable version.
2) that the last link (“To view the code online, including version history for each file, go here”) points to a page that reads: "The requested project does not exist”.

-Tom


Message: 2
Date: Fri, 10 Jan 2020 07:09:48 +0100
From: Andre Klapper <[hidden email]<mailto:[hidden email]>>
To: MediaWiki announcements and site admin list <[hidden email]<mailto:[hidden email]>>
Subject: Re: [MediaWiki-l] [TinyMCE] TinyMCE doesn't show any of the underlying text on some pages
Message-ID:
<[hidden email]<mailto:[hidden email]>>
Content-Type: text/plain; charset="UTF-8"

On Thu, 2020-01-09 at 22:09 +0000, Schoenemann, P. Thomas wrote:
I’ve installed tinyMCE on my installation but for several pages it just doesn’t work.  I get a delay, then the tinyMCE menu, but then no text shows up below it for editing (even though there is text, and I can see it by selecting “Edit source” instead of “Edit” (which invokes tinyMCE).  I’m running mediawiki 1.31.0, and my server is running 7.3.13 (which I can’t change).  Any ideas?

FYI I installed tinyMCE by going to my extensions folder and doing:

git clone
https://gerrit.wikimedia.org/r/mediawiki/extensions/TinyMCE.git

Sounds like you installed git master (=unstable development 1.35.x
version) of TinyMCE together with an outdated insecure MediaWiki version (1.31.0).

Does this problem still happen with a maintained MediaWiki version (currently 1.31.6 for LTS, see https://www.mediawiki.org/wiki/Download
and https://www.mediawiki.org/wiki/Manual:Upgrading ) and the corresponding TinyMCE branch (REL1_31)?

andre
--
Andre Klapper (he/him) | Bugwrangler / Developer Advocate https://blogs.gnome.org/aklapper/




------------------------------

Subject: Digest Footer

_______________________________________________
MediaWiki-l mailing list
[hidden email]<mailto:[hidden email]>
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l


------------------------------

End of MediaWiki-l Digest, Vol 196, Issue 5
*******************************************


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l



_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l