[MediaWiki-l] [reminder] Pywikibot will end Python 2 support in July!

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] [reminder] Pywikibot will end Python 2 support in July!

Martin Urbanec
As the last release of Python 2 is finally out, the July release of
Pywikibot is going to be the **last release that supports Python 2**.
Support of Python 3.4 and MediaWiki older than 1.19 is also going to be
dropped. After this release, Pywikibot is not going to receive any further
patches and bug fixes related to those Python and MediaWiki versions.
Functions and other stuff specific to Python 3.4, Python 2.x or MediaWiki
older than 1.19 will be removed.

For your convenience, this release is marked with a "python2"
git tag and it is also the last 3.0.x release. In case you really need it,
the Pywikibot team created /shared/pywikibot/core_python2 repository in
Toolforge and a python2-pywikibot package in software repositories of some
operating systems.

The Pywikibot team strongly recommends that you migrate your scripts from
Python 2 to Python 3. The migration steps were described in the previous
message, which can be found here:
https://lists.wikimedia.org/pipermail/pywikibot/2020-January/009976.html
Detailed
plan of Python 2 deprecation with dates is described here:
https://www.mediawiki.org/wiki/Manual:Pywikibot/Compatibility

If you encounter any problems with the migration, you can always ask us
here: https://phabricator.wikimedia.org/T242120

Best regards,

Pywikibot team
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l